I have cleared my cache but I am still having problems.


TECH SUPPORT: Name of your problem - Lost Data


-What kinda computer you are using - PC

-What browser you are using - Firefox

-What the problem is - The other day I completed three episodes. Now when I log on, it says that I didn't complete any of them so I have to start again.

-Who your favorite mod is - I don't know them all, so I can't fairly answer this question.


Hi! My name is Nara.


I am a Cahill, a Historian, a Greencloak and an Earth Mage.


Remember Emerald <3

In addition to my problem, once I try to re-complete the episode, all the data is lost as soon as I exit it to go to the vault or to another episode.


It's a bit annoying.

Hi! My name is Nara.


I am a Cahill, a Historian, a Greencloak and an Earth Mage.


Remember Emerald <3

That's good and all, but I have a BIG problem. When I want to digitize a book, it says the ditgitalizations, but it doesn't show the box where I type the book in. What do I DO!?


Also, episode 1 won't load, even though I went to that website and corrected Mozilla Firefox. Also, even when I finished episode 2 and 3, it says it is still incomplete, and my medals and items don't show.


several people, including myself, have bugs. Try using other browsers (Safari works for me) or contacting through e-mail (top bar)

cleverdragon76 aka ClassifiedDragon108 


I am Billy




Remember Emerald




Bring Infinity ring back

I don't use a mac, though. I use a PC



I don't hae a Mac. You can download SAfari from a PC. Just google it.

cleverdragon76 aka ClassifiedDragon108 


I am Billy




Remember Emerald




Bring Infinity ring back

Thank you!


TECH SUPPORT: It takes absolutely FOREVER to load.

An Acer PC

Internet Explorer

Above: It takes forever to load.

Not saying. ;3


...good morning


logical one


mm, salty


"i am so sorry but you just ate our friend could you please spit him out?"

~morningstar <~~our collective name


lets try not to screw up 2018, okay?





Tech Support : Kevin


Infinity Ring books (1 and 5)

It won't let me open 1 and I cannot input the code for 5.


Also, for most of my achievements, the vault has lost or won't save them.


MacAir Pro



im using a dell computer (windows 10)

i use internet explorer

my game wont load, it does the opening bit then just wont load.

my fave mod is kevin p.

hey I try to play episodes. Any of them really but they take such a Looooonnnggg time to load. Any ideas?



Rangers Apprentice

Wings of Fire

Spirit Animals






Animal Lover


"I've been thinking..."

"And here I am without a pen or paper to record this momentous event." -Rangers Apprentice


Try changing the browser. It has worked for me some times.

cleverdragon76 aka ClassifiedDragon108 


I am Billy




Remember Emerald




Bring Infinity ring back

lol, who ur fav mod is. XD


uhh, Windows 10...

Chrome/Internet Explorer (I tried both)

Unity will not load

I am brand new, So I have only heard of you so far. On the SAMB though, I would say...King Keith I guess.

Ru Bibi... Or Melayia... Or Opal... :3


Proud Christian!

X-Men and HTTYD 4 lyf!

Minecraft and Flyff 4 lyf!

Reader, Writer, and RPer!

Wolf-girl at heart





Game One Isn't Working. I'm Reloading It A Lot, But The Tunnel Is Not Loading. Advice?





Sorry, I'd follow step 3, but I don't know how to make a new thread. (Not exactly intuative.)




Episode 1 is not loading.  The game loads and the initial clip play, then it won't load the next section. I've waited patiently for 10 minutes...still says loading. I cleared my cash, and tried again. No joy. So step 3.


Windows 10, compter is less that 2 years old HP pavilion, using Firefox latest version.


Hope this gets a response quickly.....Really sucks that you have to play a computer game before you can read the next book and not be lost on the plotline.


i've been having problems on episode 8






A... Wait, what was i saying?




"If you want something in this life, you have to work for it. Now quiet! They're about to announce the lottery numbers!"

 -Homer Simpson




TECH SUPPORT: the loading screen doesn't work


In the post itself, please include

-What kinda computer you are using : Windows 7

-What browser you are using : Internet explorer (my normal one is chrome though but i use IE for this)

-What the problem is : After the intro with like the person saying  all that you have to fix the breaks and everything the loading screen with no animation or something doesn't do anything

-Who your favorite mod is : Well I'm new to this so I don't have one. :/

Breaking Donut and any others having trouble with the games: The moderators rarely (if ever) check this message board anymore. I'd advise contacting tech support for any issues you have. Simply hover over "Help" on the bar (next to Forums). There should be an option called "Contact Us". Click on it and fill out the form.


I hope this helps.



Respect IR


Remember Emerald


"See the world not as it is, but as it should be."


My Blog: /301450

Infinity Ring is a multiplatform, time travel, action adventure book series. The epic begins in A Mutiny in Time by James Dashner. Join the quest to save history, and use your Hystorian's Guide to play the online game on the website or with the mobile app.

More from Scholastic for fans of Infinity Ring: Join the hunt for the 39 Clues! Follow Amy and Dan Cahill in this interactive, action adventure book series, beginning with The Maze of Bones by Rick Riordan. Start your own worldwide Clue hunt by going on the website to play online games and complete secret missions.

SCHOLASTIC, INFINITY RING, THE 39 CLUES, and associated logos are trademarks and/or registered trademarks of Scholastic Inc.
© 2011 — 2018 Scholastic Inc. All rights reserved.