I have completed Episodes 3, 4, and 5, gotten all required photos, found the weapons and scrolls in Episode 3, found the herbs and the bamboo book in Episode 4, gotten all of the plants and tools in Episode 5, digitized the first six books, and only five of my medals are showing up. This is really ticking me off and I want to know what is going on, namely because I've played each episode repeatedly about five times each in the past two hours, and it's really annoying that I wasted my Saturday afternoon on things I'm getting zero credit, because I could have gone to the library or cleaned my room today. I've also tried reloading the page and it's still not working, so what should I do? 

 

rrrrowww!long live thunderclan

from squirrelflight and leafpool

we love you all! :):):):):):):):):):)

BELIEVE IN STARCLAN

Try using another browser. You can also e-mail for support. I have had that problem since a lot of time and it hasn't gotten fixed, but you might get lucky.

cleverdragon76 aka ClassifiedDragon108 

 

I am Billy

 

 

 

Remember Emerald

 

 

 

Bring Infinity ring back

Infinity Ring is a multiplatform, time travel, action adventure book series. The epic begins in A Mutiny in Time by James Dashner. Join the quest to save history, and use your Hystorian's Guide to play the online game on the website or with the mobile app.

More from Scholastic for fans of Infinity Ring: Join the hunt for the 39 Clues! Follow Amy and Dan Cahill in this interactive, action adventure book series, beginning with The Maze of Bones by Rick Riordan. Start your own worldwide Clue hunt by going on the website to play online games and complete secret missions.

SCHOLASTIC, INFINITY RING, THE 39 CLUES, and associated logos are trademarks and/or registered trademarks of Scholastic Inc.
© 2011 — 2017 Scholastic Inc. All rights reserved.